Ubuntu 14.04 Upgrade: unlösbares Problem beim Berechnen - Tobi's Welt

Ubuntu 14.04 Upgrade: unlösbares Problem beim Berechnen

Ubuntu 14.04 Upgrade: Ein unlösbares Problem trat beim Berechnen der Aktualisierung auf.

 

Gestern wurde die neue LTS-Version von Ubuntu, „Trusty Thar“, veröffentlicht. Also Zeit für mich mit dem Ubuntu 14.04 Upgrade zu starten. Leider wurde mein Upgrade recht schnell abgewürgt, sowohl der grafische Updater als auch die Konsolenvariante brachen beide ab.

„Ein unlösbares Problem trat beim Berechnen der Aktualisierung auf.“

Die Suche

Was soll man mit dieser Meldung denn bitte anfangen? Etwas ratlos habe ich mich auf die (Google-)Suche nach der Ursache gemacht, allerdings nur ältere Fälle mit anderen Releases und jeweils eigenen Ursachen gefunden. Aber bei Ask Ubuntu habe ich einen Beitrag gefunden, der auf ein Log des Updaters unter /var/log/dist-upgrade/apt.log verweist.

Dort habe ich wie empfohlen dann nach „Broken“ gesucht, und etliche Pakete gefunden die entsprechend geflaggt waren. Keine Überraschung, ich teste gerne mal neue Sachen. Um einen Startpunkt für die Fehlersuche zu haben schaute ich nach dem ersten auffälligen Eintrag, gefunden in Zeile 799 (von 3295).

Installing libgles2-mesa as Hängt ab von of libqt5gui5
MarkInstall libgles2-mesa [ amd64 ] < none -> 10.1.0-4ubuntu5 > ( libs ) FU=0
libgles2-mesa:amd64 Hängt ab von on libglapi-mesa [ amd64 ] < 10.2.0~git20140331.ec4b8d16-0ubuntu0ricotz~saucy > ( libs ) (= 10.1.0-4ubuntu5) can’t be satisfied!
MarkDelete libgles2-mesa [ amd64 ] < none -> 10.1.0-4ubuntu5 > ( libs ) FU=0

Die Ursache

Man beachte das „can’t be satisfied!“ und „git“ in der angegebenen Version. Ein installiertes Paket fordert eine Version einer Abhängigkeit an die nicht erfüllt werden kann. Die Versionsnummer deutet auf ein Entwicklungsrelease hin, vermutlich aus einem PPA (Der Release Upgrader deaktiviert alle PPAs, daher kann die angefragte Version nicht gefunden werden). Ein „sudo apt-cache policy libgles2-mesa“ verrät folgendes:

libgles2-mesa:
Installiert: (keine)
Installationskandidat: 10.2.0~git20140331.ec4b8d16-0ubuntu0ricotz~saucy
Versionstabelle:
10.2.0~git20140331.ec4b8d16-0ubuntu0ricotz~saucy 0
500 http://ppa.launchpad.net/xorg-edgers/ppa/ubuntu/ saucy/main amd64 Packages
9.2.1-1ubuntu3 0
500 http://archive.ubuntu.com/ubuntu/ saucy/main amd64 Packages
9.2.0~git20130701.acc6a141-0ubuntu0sarvatt~quantal 0
100 /var/lib/dpkg/status

Die Lösung

Das kollidierende Paket stammt also aus dem „xorg-edgers“ PPA. Also kurz mit „sudo ppa-purge xorg-edgers“ das PPA entfernt, und alle Pakete mit den jeweiligen Ubuntu-Versionen ersetzt.

Das Ubuntu 14.04 Upgrade

Jetzt klappt’s auch mit „do-release-upgrade“ und dem Ubuntu 14.04 Upgrade.

18. April 2014 von Tobias
Kategorien: Linux, Ubuntu
Schlagwörter: , , ,
4 Kommentare

Gelesen: 3696 · Heute: 4 · Zuletzt: 15. November 2019

Kommentare (4)

  1. Super Danke hat super geholfen

  2. Gibt es einen Befehl um alle Pakete mit den jeweiligen Ubuntu-Versionen zu ersetzen? Habe auch Ubuntu 13.10.

    • So weit ich weiß nein. Du müsstest jedes einzelne PPA manuell purgen.

      Man könnte natürlich ein Shellscript machen das jedes PPA einliest um es dann zu purgen, aber dann kann man es auch gleich selbst machen

Kommentar verfassen

Diese Website verwendet Akismet, um Spam zu reduzieren. Erfahre mehr darüber, wie deine Kommentardaten verarbeitet werden.

Follow

Get every new post delivered to your Inbox

Join other followers: